Отладка расчета себестоимости в ERP - просмотр изменений временных таблиц

Публикация № 1291127 09.09.20

Разработка - Практика программирования

Расчет себестоимости Управление предприятием 2 ERP

Как уследить за изменениями в сотне временных таблиц на различных этапах выполнения расчета себестоимости. Тестировалось на 1С:ERP Агропромышленный комплекс 2 (2.4.12.75)

Перед прочтением рекомендую ознакомиться с выжимкой из описания типовых методов  расчета в этой статье: //1c.smartsoft.kz/1c/articles/658048/

Для отладки расчета себестоимости будет очень удобно использовать методы сравнения данных в МВТ. Поясню. Весь расчет себестоимости - это формирование и перезапись временных таблиц. Их около 50 штук. Для того чтобы понимать, какие ВТ на каком этапе формируются, и какие данные в них меняются, я написал два метода и положил их в общий модуль.

На протяжении расчета во все методы передаётся структура ПараметрыРасчета, содержащая МенеджерВременныхТаблиц. Именно в нём и меняются ВТ, формируемые в разных этапах расчета. 
 

Функция ПолучитьОписаниеТаблицМВТ(МВТ, Параметры = Неопределено, ИмяПараметра = "") Экспорт
    
    ТаблицыМВТ = Новый ТаблицаЗначений;
    ТаблицыМВТ.Колонки.Добавить("Имя", Новый ОписаниеТипов("Строка"));
    ТаблицыМВТ.Колонки.Добавить("КоличествоЗаписей", Новый ОписаниеТипов("Число"));
    ТаблицыМВТ.Колонки.Добавить("ТЗ");
    
    
    Для Каждого цВТ Из МВТ.Таблицы Цикл
        
        новСтрока = ТаблицыМВТ.Добавить();
        новСтрока.Имя = цВТ.ПолноеИмя;
        
        ТЗ = цВТ.ПолучитьДанные().Выгрузить();
        
        новСтрока.КоличествоЗаписей = ТЗ.Количество();
        новСтрока.ТЗ = ТЗ;
        
    КонецЦикла;
    
    ТаблицыМВТ.Сортировать("Имя");
    
    
    Если Параметры <> Неопределено И Не ПустаяСтрока(ИмяПараметра) Тогда
        Параметры.Вставить(ИмяПараметра, ТаблицыМВТ);
    КонецЕсли;
    
    
    Возврат ТаблицыМВТ;
    
КонецФункции
Функция СравнитьОписанияВТ(Описание1, Описание2, ТолькоОтличия = Истина) Экспорт
    
    ОтличияОписаний = Новый ТаблицаЗначений;
    ОтличияОписаний.Колонки.Добавить("Имя", Новый ОписаниеТипов("Строка"));
    ОтличияОписаний.Колонки.Добавить("КоличествоЗаписей1", Новый ОписаниеТипов("Число"));
    ОтличияОписаний.Колонки.Добавить("КоличествоЗаписей2", Новый ОписаниеТипов("Число"));
    ОтличияОписаний.Колонки.Добавить("ЕстьВОписании1", Новый ОписаниеТипов("Булево"));
    ОтличияОписаний.Колонки.Добавить("ЕстьВОписании2", Новый ОписаниеТипов("Булево"));
    ОтличияОписаний.Колонки.Добавить("ДанныеОтличаются", Новый ОписаниеТипов("Булево"));
    ОтличияОписаний.Колонки.Добавить("ТЗ1");
    ОтличияОписаний.Колонки.Добавить("ТЗ2");
    
    Для Каждого цСтрокаОписания1 Из Описание1 Цикл
        
        новСтрока = ОтличияОписаний.Добавить();
        новСтрока.Имя = цСтрокаОписания1.Имя;
        новСтрока.ТЗ1 = цСтрокаОписания1.ТЗ;
        новСтрока.КоличествоЗаписей1 = цСтрокаОписания1.ТЗ.Количество();;
        новСтрока.ЕстьВОписании1 = Истина;
        
        СтрокиВ2Описании = Описание2.НайтиСтроки(Новый Структура("Имя", цСтрокаОписания1.Имя));
        
        Если СтрокиВ2Описании.Количество() = 0 Тогда
            новСтрока.ДанныеОтличаются = Истина;
        Иначе
            
            новСтрока.ЕстьВОписании2 = Истина;
            новСтрока.ТЗ2 = СтрокиВ2Описании[0].ТЗ;
            новСтрока.КоличествоЗаписей2 = новСтрока.ТЗ2.Количество();;
            
            
            Если новСтрока.КоличествоЗаписей1 <> новСтрока.КоличествоЗаписей2 Тогда
                новСтрока.ДанныеОтличаются = Истина;
                Продолжить;
            КонецЕсли;
            
            
            Для Каждого цКолонкаТЗ1 Из новСтрока.ТЗ1.Колонки Цикл
                Если новСтрока.ТЗ2.Колонки.Найти(цКолонкаТЗ1.Имя) = Неопределено Тогда
                    новСтрока.ДанныеОтличаются = Истина;
                    прервать;
                КонецЕсли;
            КонецЦикла;
            
            Для Каждого цКолонкаТЗ2 Из новСтрока.ТЗ2.Колонки Цикл
                Если новСтрока.ТЗ1.Колонки.Найти(цКолонкаТЗ2.Имя) = Неопределено Тогда
                    новСтрока.ДанныеОтличаются = Истина;
                    прервать;
                КонецЕсли;
            КонецЦикла;
            
            Если Не новСтрока.ДанныеОтличаются Тогда
                новСтрока.ДанныеОтличаются = Не ОбщегоНазначения.КоллекцииИдентичны(новСтрока.ТЗ1, новСтрока.ТЗ2);
            КонецЕсли;
            
        КонецЕсли;
        
    КонецЦикла;
    
    Для Каждого цСтрокаОписания2 Из Описание2 Цикл
        
        СтрокиВОписании = ОтличияОписаний.НайтиСтроки(Новый Структура("Имя", цСтрокаОписания2.Имя));
        
        Если СтрокиВОписании.Количество() = 0 Тогда
            новСтрока = ОтличияОписаний.Добавить();
            новСтрока.Имя = цСтрокаОписания2.Имя;
            новСтрока.ТЗ2 = цСтрокаОписания2.ТЗ;
            новСтрока.КоличествоЗаписей2 = цСтрокаОписания2.ТЗ.Количество();;
            новСтрока.ЕстьВОписании2 = Истина;
            новСтрока.ДанныеОтличаются = Истина;
        КонецЕсли;
        
    КонецЦикла;
    
    Если ТолькоОтличия Тогда
        ОтличияОписаний = ОтличияОписаний.Скопировать(Новый Структура("ДанныеОтличаются", Истина));
    КонецЕсли;
    
    ОтличияОписаний.Сортировать("Имя");
    
    Возврат ОтличияОписаний;
    
КонецФункции

Первый метод читает все ВТ из менеджера и возвращает таблицу значений с колонками:

  • Имя (имя временной таблицы), 
  • КоличествоЗаписей, 
  • ТЗ (непосредственно данные из временной таблицы).

Кроме того, этот метод может положить сформированную таблицу с описанием ВТ в любую структуру с произвольным ключом (параметры метода: Параметры, ИмяПараметра). Таким образом мы можем на любом этапе расчета создать "слепок" содержимого менеджера ВТ и положить его, например, в структуру "ПараметрыРасчета".

Второй метод позволяет сравнивать слепки, получившиеся в результате работы первого метода. В результате сравнения возвращается таблица, содержащая поля:

  • Имя (имя временной таблицы), 
  • КоличествоЗаписей1, 
  • КоличествоЗаписей2, 
  • ТЗ1 (непосредственно данные из таблицы первого слепка).
  • ТЗ2 (непосредственно данные из таблицы второго слепка).
  • ЕстьВОписании1 (признак того, что ВТ присутствует в первом слепке)
  • ЕстьВОписании1 (признак того, что ВТ присутствует во втором слепке)
  • ДанныеОтличаются (признак того, что Данные в таблицах с одинаковым именем отличаются - по количеству записей, или по значению полей, или по наличию таблиц)

Как этим пользоваться.
1. Запускаем расчет. Можно накидать внешнюю обработку для запуска

&НаСервере
Процедура ЗапуститьРасчетССНаСервере()
    ПараметрыЗапуска = Новый Структура;
    ПараметрыЗапуска.Вставить("АвтоматическоеТестирование", Ложь);
    ПараметрыЗапуска.Вставить("ВыполняетсяЗакрытиеМесяца", Ложь);
    ПараметрыЗапуска.Вставить("Дата", НачалоМесяца(Период));
    ПараметрыЗапуска.Вставить("МассивОрганизаций", ОбщегоНазначенияКлиентСервер.ЗначениеВМассиве(Организация));
    ПараметрыЗапуска.Вставить("МестоВызоваРасчета", "РасчетСебестоимостиКорректировкаСтоимости.Выполнить_РасчетПартийИСебестоимости");
        
    СхемаРасчета = РасчетСебестоимостиПрикладныеАлгоритмы.СхемаРасчетаПартий(ПараметрыЗапуска.Дата, ПараметрыЗапуска.МассивОрганизаций);
    Если СхемаРасчета.Количество() = 0 Тогда
        новСтрока = СхемаРасчета.Добавить();
        новстрока.Дата = КонецМесяца(ПараметрыЗапуска.Дата);
        новстрока.ИзмененоДокументов = 1;
        новстрока.Организации = ПараметрыЗапуска.МассивОрганизаций;
    КонецЕсли;
    ПараметрыЗапуска.Вставить("СхемаРасчета", СхемаРасчета);
    
    РасчетСебестоимости.РассчитатьВсе(ПараметрыЗапуска);

КонецПроцедуры


Обработка во вложении, там она ещё перепроводит проблемный документ перед расчетом.
2. Тормозим отладку перед интересующим нас методом.
3. В табло пишем:

НашОбщийМодуль.ПолучитьОписаниеТаблицМВТ(ПараметрыРасчета.МенеджерВременныхТаблиц, ПараметрыРасчета, "ТаблицыПередВыполнениемЭтапа")


4. После того как выражение вычислилось, в структуре ПараметрыЗапуска появились данные с ключом "ТаблицыПередВыполнениемЭтапа", комментим (или удаляем из табло) выражение из пункта №3, чтобы данные не перезаписались при следующих шагах
5. Выполняем интересующий нас этап и кладём его данные в структуру с новым ключом. Для этого опять пишем выражение в табло:

НашОбщийМодуль.ПолучитьОписаниеТаблицМВТ(ПараметрыРасчета.МенеджерВременныхТаблиц, ПараметрыРасчета, "ТаблицыПослеВыполненияЭтапа")


6. Сравниваем эти описания, выполняя в табло код: 

НашОбщийМодуль.СравнитьОписанияВТ(ПараметрыРасчета.ТаблицыПередВыполнениемЭтапа, ПараметрыРасчета.ТаблицыПослеВыполненияЭтапа)


В результате имеем Таблицу, содержащую отличия. Открыть её можно прямо из табло, нажав F2.
Также можно вместо этапов 5,6 просто идти по коду, вычисляя в табло выражение:
 

НашОбщийМодуль.СравнитьОписанияВТ(ПараметрыРасчета.ТаблицыПередВыполнениемЭтапа, НашОбщийМодуль.ПолучитьОписаниеТаблицМВТ(ПараметрыРасчета.МенеджерВременныхТаблиц))

Таким образом можно на любом этапе понять, какие ВТ сформировались или изменились.

Скачать файлы

Наименование Файл Версия Размер
Обработка для запуска расчета себестоимости с перепроведением проблемного документа

.epf 6,81Kb
12
.epf 6,81Kb 12 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Внешний регламент для 1С Промо

Прочие инструменты разработчика v8 Россия Абонемент ($m)

Внешний регламент сделан для тех, кто ценит свое время и время заказчика. После одноразового встраивания в конфигурацию, внешний регламент на лету позволяет добавлять, изменять внешние модули, которые могут выполнятся как регламентные задачи с указанным интервалом или запускаться в ручном режиме для отладки. Все модули (внешние обработки) находятся и выполняются на стороне сервера, что позволяет исключить подмену алгоритмов со стороны клиента.

1 стартмани

05.03.2020    6591    8    moolex    11    

Отключение применения обязательного учета редакции ФСБУ 5/2019 "Запасы" до 01.01.2022 года

Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

С 2021 года вступает в силу действие ФСБУ 5/2019, тем самым он заменяет нормативные акты по бухгалтерскому учету запасов. Поэтому с 2021 года затраты, учтенные на счете 26, в полном объеме включаются в расходы текущего периода, при закрытии месяца списываются на счет 90.08. Данное расширение дает отсрочку данному функционалу до 01.01.2022 года.

1 стартмани

15.07.2021    696    0    iones    2    

Изменение состояния последовательности "Документы организаций" (Бухгалтерия 3.0)

Закрытие периода v8 v8::БУ БП3.0 БУ Абонемент ($m)

Обработка позволяет пропустить этап Перепроведения документов при Закрытии месяца.

2 стартмани

14.07.2021    493    1    tanat74    0    

Программное формирование отчетов в БП 3.0 на примере оборотно-сальдовой ведомости по счету

Практика программирования Оборотно-сальдовая ведомость, Анализ счета Бухгалтерские v8 v8::БУ v8::СКД БП3.0 Россия БУ Абонемент ($m)

Порой возникает задача получить программно результат отчета на основе СКД в виде табличного документа. В данной статье будет описан один из вариантов реализации данной задачи.

1 стартмани

14.07.2021    834    0    arman1997    0    

Подсистема "Показатели объектов" Промо

Прочие инструменты разработчика v8 1cv8.cf Абонемент ($m)

Если вашим пользователям нужно вывести в динамический список разные показатели, которые нельзя напрямую получить из таблиц ссылочных объектов, и вы не хотите изменять структуру справочников или документов - тогда эта подсистема для вас. С помощью нее вы сможете в пользовательском режиме создать свой показатель, который будет рассчитываться по формуле или с помощью запроса. Этот показатель вы сможете вывести в динамический список, как любую другую характеристику объекта. Также можно будет настроить отбор или условное оформление с использованием созданного показателя.

2 стартмани

06.03.2021    4914    5    pila86    16    

Закрытие 26 счета на 20.01 для 1С: Бухгалтерии 3.0 в 2021 году

Закрытие периода v8 v8::БУ БП3.0 БУ Налог на прибыль Абонемент ($m)

Включение распределения косвенных расходов на 20.01 в 2021 году.

3 стартмани

16.04.2021    2898    19    serge_msk    9    

БГУ 1. Закрытие счетов группы 109

Бухгалтерский учет Закрытие периода v8 v8::БУ БГУ Государственные, бюджетные структуры Россия Госбюджет Абонемент ($m)

Полезно для ЦБ и учреждений с учётом по ИФО. Формирует "Закрытие производственных счетов", формирует и заполняет "Списание затрат по услугам". Есть функция отмены проведения и перезаполнения.

1 стартмани

16.02.2021    1464    1    strig_85    0    

Тестовое задание на вакансию "Программист 1С" №6

Практика программирования v8 v8::БУ БП3.0 Абонемент ($m)

Выполненное тестовое задание на вакансию программист-стажер в крупный франч. Тестировалось на платформе 8.3.13.1513 и конфигурации БП 3.0.61.47.

1 стартмани

23.01.2021    2056    1    Sungang    0    

Markdown-editor в 1С (с сохранением в HTML) Промо

Универсальные обработки Прочие инструменты разработчика v8::УФ 1cv8.cf Абонемент ($m)

В этой обработке вы пишете свой текст, используя синтаксис Markdown, а на выходе получаете чистый HTML-код, избавленный от JS-библиотеки, которая его сформировала. Совместим с Webkit и IE.

1 стартмани

04.07.2019    10714    18    riposte    6    

FormCodeGenerator Программная доработка форм. Часть 2 (Режим работы "Режим сравнения форм") на примере ERP 2.5

Практика программирования Адаптация типовых решений Прочие инструменты разработчика v8 1cv8.cf Абонемент ($m)

Данная публикация является продолжением описания функционирования обработки "FormCodeGenerator " в режиме сравнения форм и генерирования кода на основании сравнения. Подходит для перевода уже доработанных форм с интерактивной доработки на программную. Данный режим работы обработки снизит издержки при дальнейших обновлениях конфигураций.

5 стартмани

21.12.2020    6791    21    huxuxuya    11    

Перенос движений документа из архивной базы при закрытии квартала

Перенос данных из 1C8 в 1C8 Закрытие периода v8::БУ 8.3.14 БП3.0 Россия БУ Абонемент ($m)

Решение проблемы изменения проводок у документа в закрытом квартале.

2 стартмани

03.11.2020    2208    2    Kref    3    

Автоматизированное заполнение документа "Списание НДС" по остаткам регистра "НДС Предъявленный" (счет 19) для БП 3.0

Обработка документов Закрытие периода v8 v8::БУ БП3.0 Россия БУ НУ НДС Абонемент ($m)

Доработка позволяет одним нажатием заполнить документ "Списание НДС" всеми документами с входным НДС, т.е. остатками по регистру "НДС предъявленный" (счет 19).

3 стартмани

03.10.2020    3496    17    vakrikun    10    

Помощник по закрытию месяца для УТ 11.3 Промо

Обработка документов Закрытие периода Закрытие периода v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Помощник по закрытию месяца для УТ 11.3. Имеет две функции: обнуление товаров "К оформлению" в интеркампани и обнуление отрицательных остатков в регистре "Себестоимость товаров".

5 стартмани

10.11.2017    29091    11    Zalipaka    1    

Интерактивная справка по объектам 1С (подключаемое расширение)

Практика программирования Работа с интерфейсом v8 ERP2 Абонемент ($m)

База знаний, подключаемая к объектам основной базы. Пополняется интерактивно, формируется в виде статей прямо в 1С (текст, картинки, таблицы, ссылки). Есть возможность прикрепления файлов, привязки к объектам 1С, возможности рейтинга и комментирования пользователями.

3 стартмани

29.09.2020    12963    73    sapervodichka    43    

Закрытие месяца за выбранный период скопом для Бухгалтерии 3.0

Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Часто бывает ситуация - бухгалтера залезли в прошлый период, надо все перезакрыть и срочно. Если 1, 3 месяца - не проблема, а вот если год и более напряжно - вот для этих случаев я и сделала данную обработку.

2 стартмани

10.09.2020    2041    18    lenna1c    0    

Консоль кода для управляемых форм

Прочие инструменты разработчика v8 v8::УФ 1cv8.cf Абонемент ($m)

Консоль кода для управляемых форма с подсказками и подсветкой синтаксиса.

1 стартмани

17.07.2020    22316    340    salexdv    296    

Корректировка остатков регистров бухгалтерии (обычные и управляемые формы) Промо

Свертка базы Универсальные обработки Чистка базы Закрытие периода v8::БУ v8::УФ 1cv8.cf БУ НУ Абонемент ($m)

Внешняя обработка, предназначенная для удобного исправления остатков по регистрам бухгалтерии (Хозрасчетный, Налоговый или любой другой) посредством автоматизации ввода корректировочного документа ("Операция", "Корректировка записей регистров"), приводящего регистр в нужное состояние остатков от текущего. Удобна для массовых правок остатков по бухгалтерскому и налоговому учету на какую-то дату (обычно перед реорганизацией учета, сверткой базы и т.п.)

2 стартмани

03.06.2017    36665    224    stvorl    28    

Распределение косвенных затрат для Бухгалтерии редакции 3.0

Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработка предназначена для распределения 25 и 26 счетов пропорционально суммам реализации по номенклатурным группам.

10 стартмани

25.05.2020    3130    5    vitalbasl    3    

БП 3.0, Закрытие месяца, Отключение проверок операций прошлых периодов

Закрытие периода v8 v8::БУ БП3.0 БУ Абонемент ($m)

Расширение конфигурации, отключающее ошибки прошлых периодов, которые блокируют закрытие текущего месяца. Например, "Нарушена последовательность регламентных операций" и т.д.

1 стартмани

13.05.2020    10751    28    sapervodichka    15    

Инструменты оптимизации для 1С на MS SQL Server

Прочие инструменты разработчика v8 v8::УФ 1cv8.cf Абонемент ($m)

Набор базовых инструментов для поиска узких мест в работе 1С на MS SQL Server.

1 стартмани

15.12.2019    19645    228    berezdetsky    23    

Списание (корректировка) задолженности контрагентов УНФ 1.6 Промо

Дебиторская и кредиторская задолженность Обработка документов Дебиторская и кредиторская задолженность Закрытие периода v8 УНФ Украина БУ Абонемент ($m)

Обнуление задолженности контрагентов в конфигурации "Управление небольшой (нашей) фирмой" версии 1.6 с помощью документа "Корректировка регистров".

1 стартмани

24.07.2019    29641    20    DMon    1    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы Jenkins SonarQube v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    33504    27    Stepa86    46    

Простое закрытие затратных счетов для Бухгалтерии 3.0

Закрытие периода Закрытие периода v8::БУ v8::УФ БП3.0 БУ Абонемент ($m)

Позволяет получить суммы затрат за период и с отборами и закрыть их на выбранный счет и аналитику, тестировалось на 1С:Предприятие 8.3 (8.3.13.1690) Бухгалтерия предприятия, редакция 3.0 (3.0.70.39)

5 стартмани

29.07.2019    5428    9    MikeStav    6    

Формирование записей КУДиР из проводок для ленивых бухгалтеров

Обработка документов Закрытие периода Закрытие периода v8 v8::БУ БП3.0 Россия БУ НУ УСН Абонемент ($m)

Формирование записей КУДиР из проводок для ленивых бухгалтеров или Корректировка записей Книга учёта доходов и расходов УСН для ленивых бухгалтеров. Однажды у бухгалтерии возникла ситуация в новой базе делать "правильные"(по мнению бухгалтеров) записи в КУДиР УСН . Остатки по КУДиР не вносились и не было у них желания вносить. У меня мнение другое , но сделал как просили.) .. Была поставлена задача сформировать "правильные" записи в КУДиР из проводок. Для всех реализаций содержание записи меняется на Списание себестоимости и сумма берется из проводки при списании товаров. Вторая задача - заменить в уже сформированных записях КУДиР на содержание удобное для бухгалтера. Процесс работы построен на переводе затронутых документов в режим Ручная корректировка и замены в них реквизита записи Содержание проводки по заранее подготовленному шаблону Данная обработка будет интересна тем, кто хочет поменять в отчете КУДиР содержание. Для программистов - как шаблон по возможным корректировкам регистров. Проверено на конфигурации Бухгалтерия предприятия, редакция 3.0 (3.0.68.61) . Код открыт

1 стартмани

23.07.2019    8308    27    МимохожийОднако    9    

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    25942    7    m-rv    91    

Редактирование (установка) даты окончания действия счетов ЕПСБУ в БГУ

Закрытие периода Закрытие периода v8 v8::БУ БГУ Государственные, бюджетные структуры БУ Абонемент ($m)

При обновлении «1С:Бухгалтерия государственного учреждения, редакция 1.0» (1С:БГУ) на версию 1.0.56.7 не произошла установка даты окончания действия 31.12.2018 у счетов, которые прекратили свое действие в 2018 году. К сожалению, это заметили несколько релизов спустя и вернуться, чтобы разобраться в причинах некорректного обновления, возможности не было. В связи с этим, создана обработка, с помощью которой можно установить дату окончания действия выбранных счетов.

1 стартмани

18.07.2019    8494    31    delta    2    

Решение проблем учета материалов в эксплуатации. УПП, РАУЗ

Учет ТМЦ Практика программирования Учет ТМЦ Разработка v8 v8::БУ УПП1 Россия БУ Абонемент ($m)

Если в вашей организации в течение одного месяца могут происходить несколько перемещений одного и того же материала в эксплуатации между физическими лицами, то УПП с РАУЗ неверно распределяет погашенную стоимость. Эта публикация поможет исправить проблему.

1 стартмани

04.07.2019    5182    21    AnRyb    4    

Дозакрытие месяца по статьям затрат

Закрытие периода Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработка "дозакрывает" счета 20,23,25,26 в разрезе статей затрат.

1 стартмани

30.05.2019    6884    28    Mihasya    15    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    34913    93    m-rv    58    

Закрытие затрат с перераспределением счета 23 для 1С: Бухгалтерии 8.3

Закрытие периода Обработка документов Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Внешняя обработка, которая позволяет, не внося изменения в конфигурацию 1С: Бухгалтерия 3.0, перезакрыть затраты путем сторнирования проводок, сделанных стандартным способом, и создания Операции, введенной вручную.

1 стартмани

04.05.2019    5627    5    gerasimovaol@rambler.ru    5    

Восстановление последовательности документов по зачету аванса

Обработка документов Закрытие периода Оптовая торговля Закрытие периода Оптовая торговля v8::БУ БП3.0 Россия БУ НУ НДС Абонемент ($m)

Обработка помогает восстановить движения между субсчетами 60.01 и 60.02, а так же между 62.01 и 62.02 с учетом хронологии первичных документов. Проверялось на Бухгалтерия Предприятия 3.0.56-3.0.68 и Бухгалтерия Предприятия КОРП таких же релизов.

2 стартмани

26.03.2019    5485    17    Keath    7    

Автоматический зачет доплаты НДС 2% в 2019 году, по авансам полученным ранее 2019 года, при отгрузках в 2019 году

Оптовая торговля Оптовая торговля Закрытие периода v8::БУ БП3.0 Россия БУ НДС Абонемент ($m)

При частичной отгрузке в 2019 году 1С БП 3 в зачет возьмет полученный аванс в 2018 году без учета доплаты НДС 2% в 2019, возникнут расхождения между счетами 62.02 и 76.АВ Работа обработки проверялась на релизе 3.0.68.58.

5 стартмани

20.03.2019    4314    0    detro    0    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    32867    20    mvxyz    17    

Закрытие долгов по зарплате в БП 3.0

Зарплата Зарплата Закрытие периода v8::БУ v8::УФ БП3.0 Россия БУ Абонемент ($m)

Обработка закрытия долгов зарплаты по регистрам.

2 стартмани

20.03.2019    6266    61    dipolm    7    

[БП 3.0] Исправление остатка по видам платежей в госбюджет, которые использовались до 2017 г.

Закрытие периода Обработка документов Закрытие периода v8::БУ БП3.0 Россия БУ ФОМС, ПФ, ФСС Абонемент ($m)

В БП 3.0 есть субконто "Виды платежей в бюджет (фонды)" (суть - Перечисление), в котором есть три позиции, выбрать которые сейчас в документах или операциях невозможно (ну почти невозможно, как заметил gsmirnov :-) ), а остатки по этим субконто у многих висят, и убрать их не получается... Это решение. Платформа 8.3.13.1690 БП 3.0.68.58

1 стартмани

21.02.2019    6315    6    Alex_E    2    

Управление последовательностью документов (обработка для БП 3.0)

Обработка документов Универсальные обработки Рабочее место Закрытие периода v8::БУ БП3.0 УХ БУ Абонемент ($m)

Наиболее универсальная и удобная обработка по управлению последовательностью документов в конфигурациях на базе "1С:Бухгалтерия 3.0". Быстрое отображение, гибкие динамические отборы, изменение состояний документов, удаление из последовательности, групповые действия, удобная навигация по периодам.

2 стартмани

14.01.2019    11259    60    mbreaker    0    

Универсальное закрытие счетов для 1С:Бухгалтерия предприятия 3.0 Промо

Обработка документов Закрытие периода Закрытие периода v8::БУ БП3.0 Россия БУ Абонемент ($m)

Внешняя обработка позволяет закрывать счета бухгалтерского учета в ноль, распределять, переносить остатки, обороты бухгалтерского, налогового учета, количества, валютные суммы. Позволяет настроить и сохранить алгоритмы для периодического формирования бухгалтерских операций.

3 стартмани

13.12.2017    39903    297    leha2403    37    

Инструменты бухгалтера: Групповое закрытие месяцев

Закрытие периода Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Помощник группового закрытия позволяет закрывать последовательно сразу несколько месяцев в Бухгалтерии 3.0.

1 стартмани

12.12.2018    8039    37    Bazil    5    

Исправление нарушений последовательности

Закрытие периода Обработка документов Закрытие периода v8::БУ v8::УФ БП3.0 БУ Абонемент ($m)

Внешняя обработка для ручного удаления документа из последовательности. Тестирование: Платформа (8.3.10.2650), Бухгалтерия предприятия 3.0 (3.0.64.48).

1 стартмани

25.10.2018    5807    3    Legavaz    0    

Анализ последовательности "Документы организаций" и неактуальных регламентных операций для проведения операции "Закрытие Месяца"

Закрытие периода Обработка документов Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Эта обработка основана на методике, содержащийся в статье «Как заставить закрытие месяца не ругаться на прошлые периоды в 1С:Бухгалтерия 8.3 (редакция 3.0)» (https://helpme1c.ru/kak-zastavit-zakrytie-mesyaca-ne-rugatsya-na-proshlye-periody-v-1sbuxgalteriya-8-3-redakciya-3-0) и позволяет упростить все манипуляции с данными. Перед ее использованием - прочите эту статью.

1 стартмани

01.10.2018    8300    20    unclevad    0    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    32611    73    vasvl123    9    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    26223    14    RocKeR_13    16    

Консоль Внедренца v.3.6.2

Консоль запросов Прочие инструменты разработчика v8 1cv8.cf Абонемент ($m)

Идея данной обработки заключается в создании простого, функционального и универсального инструментария для внедренцев и программистов 1С, который будет работать как в толстом клиенте на обычных и на управляемых формах, так и в тонком клиенте. Интерфейс и логика работы максимально идентичны у обычных форм и управляемых. Инструментарий включает в себя: Консоль кода, Консоль запросов, Консоль отчетов (СКД), Универсальную обработку объектов, Средства для работы с таблицами базы данных 1С, Редактирование регистров сведений базы, Инструмент по работе с табличными документами - загрузка данных из табличного документа.

1 стартмани

27.08.2018    27144    425    evvakra    42    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    50049    66    dsdred    17    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    34043    31    informa1555    30    

Подмена подразделений в регистрах сведений регламентной операции

Свертка базы Закрытие периода Закрытие периода v8::БУ v8::УФ БП3.0 БУ Абонемент ($m)

При свертке дублей подразделений бывает, что штатная обработка не может выполнить замену из-за того, что регистры сведений Регламентных операций не могут записать несколько записей с одинаковыми измерениями. Данная обработка позволяет до свертки подразделений выполнить подмену подразделения в регистре и свернуть записи в измерениях.

1 стартмани

24.07.2018    7505    10    woldemarr    0